Polyglot 1.4.0

Polyglot version 1.4.0 is out!

gem install jekyll-polyglot

statisch nicht relativiert href

Diese Version bietet eine neue liquid block tag ` {% static_href %}href=”…”{% endstatic_href %} ` die verwendet werden kann, um zu erstellen href attributes in anchor tags das sind nicht relativiert von Polyglot.

Jekyll-Polyglot ist ziemlich gierig und naiv in seiner Relativierung, und wenn Sie also eine URL wollen, die explizit statisch ist (wie für einen Sprachumschalter machen, apropos), dies liquid tag will helfen Sie, das entwirrt zu konstruieren href=”…” tag in anchor elements.

Exklusive Generierung der Website-Sprache

Polyglot 1.4.0 fügt Unterstützung für lang-exclusive: [ ] frontmaterie in Dokumenten. Wenn dieses Dokument einem Dokument hinzugefügt wird, beschränkt es die Generierung des Dokuments auf diese bestimmte Sprache.

---
lang-exclusive: ['de']
---

Auf diese Weise können Sie steuern, in welchen Sprachen ein Dokument angezeigt werden kann, auch wenn dieses Dokument auf der Standardsprachensite möglicherweise keine Entsprechung aufweist.

Einige umbenennen liquid tags

The {% static_href %} tag is also available as {% Static_Href %} , and the existing {% I18n_Headers %} tag now can be called as {% i18n_headers %}

Möchten Sie Ihre Sprache sehen?

Ich suche Freiwillige, die das sehen möchten Jekyll-Polyglot homepage in Ihrer Herkunftssprache vertreten! Wenn Sie diese Software hilfreich finden und Ihre Sprache dargestellt sehen möchten, wenden Sie sich einfach an github issues.