Polyglot 1.4.0

Polyglot version 1.4.0 is out!

gem install jekyll-polyglot

statique non relativisé href

Cette version fournit un nouveau liquid block tag ` {% static_href %}href=”…”{% endstatic_href %} ` qui peut être utilisé pour créer href attributes in anchor tags qui ne sont pas relativisés par Polyglot.

Jekyll-Polyglot est assez gourmand et naïf dans sa relativisation, et donc si vous voulez une url implicitement statique (comme pour faire un sélecteur de langue, au fait), ce liquid tag will vous aider à construire ce démêlé href=”…” tag in anchor elements.

Génération exclusive de langage de site

Polyglot 1.4.0 ajoute le support pour lang-exclusive: [ ] frontmatter dans les documents. S’il est ajouté à un document, ce frontmatter limitera la génération du document à cette langue spécifique.

---
lang-exclusive: ['fr']
---

C’est un moyen de contrôler quelles langues peuvent voir un document, même si ce document n’a pas d’équivalent dans le site de langue par défaut.

Renommer quelques-uns liquid tags

The {% static_href %} tag is also available as {% Static_Href %} , and the existing {% I18n_Headers %} tag now can be called as {% i18n_headers %}

Vous voulez voir votre langue en vedette?

Je recherche des volontaires qui aimeraient voir le Jekyll-Polyglot homepage représenté dans votre langue d’origine! Si vous trouvez ce logiciel utile et que vous souhaitez voir votre langue représentée, contactez simplement le github issues.