Polyglot 1.3.2

Polyglot versie 1.3.2 is gepubliceerd! Probeer het uit!

gem install jekyll-polyglot

Deze release was mede mogelijk gemaakt met de hulp van de volgende GitHub-gebruiker

lang_from_path instelling leidt documenttaal af van relatieve pad

Deze publicatie voegt een nieuwe booleaanse configuratie-instelling toe lang_from_path. Als deze op true is gezet, zegt deze optie tegen Polyglot om de basistaal af te leiden van het bijbehorende subpad als de lang in de frontmatter niet is ingesteld. Deze instelling werkt goed samen met andere vertalingsonderhoudstools zoals po4a.

Verbeterde logica voor relatievering van relatieve en absolute URL’s

excluded_from_localization bestanden hebben trailing slashes aan hun paden toegevoegd als ze directories zijn. Daarnaast, deze bestanden worden anders gematched door de relatieve en absolute URL regex matchers. Dit verhoogt de nauwkeurigheid van URL-relatievering gebaseerd op feedback van gebruikers.

Polyglot 1.3.0

Een nieuwe versie van Polyglot is gepubliceerd! Probeer het uit!

gem install jekyll-polyglot

Deze publicatie is mede mogelijk gemaakt de de volgende GitHub-gebruikers:

Recursief samenvoegen van taalspecifieke site.data

Taalspecifieke inhoud die in je site.data directory is gedefinieerd zal nu recursief worden samengevoegd, zodat active_lang content voorrang heeft op default_lang content, die weer voorrang heeft op niet-taalspecifieke content. (#59)

Bouw bestanden die geen taal hebben voor de default_lang site root

Als de default_lang niet in de languages gedefinieerd is, garandeert dit dat bestanden zonder taal (zoals uitgesloten van lokalisatie) nog steeds naar de site root worden geschreven. (#65)

Performanceverbeteringen en fiksen voor i18n_headers tag

Documentverwerking is nu sneller, en fiksen zijn gemaakt aan de i18n_headers voor wanneer de site.url gedefinieerd is. (#67)

Maatwerksleutels voor active_lang site payload

Dit maakt het mogelijk maatwerksleutels te definiëren met de active_lang, dit maakt interoperabiliteit mogelijk tussen Polyglot en andere plug-ins en thema’s. (#68)

Polyglot 1.2.4

Een nieuwe versie van Polyglot is gepubliceerd! Probeer het uit!

gem install jekyll-polyglot

Deze publicatie is mogelijk gemaakt door de vriendelijke hulp van de GitHub-gebruiker vlsi, die heeft geholpen wat bugs te fiksen en nieuwe features toe te voegen:

Ondersteuning vertalen van absolute URL’s

Polyglot zal nu je site.url vertalen, zodat absolute URL’s ook vertaald worden.

Vertaling van alle Jekyll collecties

Jekyll collecties is een redelijk nieuwe feature. Deze update vertaalt alle geregistreerde collecties, niet alleen posts en pagina’s.

Gebruik taalspecifieke _data voor site.data rich text als site.data[:lang] aanwezig is

Rich text op top level die op taal is gesorteerd wordt toegekend aan de site.data tijdens het bouwen van de site. Voorheen, toen rich text werd gerendered, moest je dit doen:

{{ site.data[site.active_lang].richTextString }}

Rich text kan nu worden gerendered met alleen:

{{ site.data.richTextString }}

De I18n_Headers tag gaat nu standaard naar site.url als die niet is ingevuld

Gebruikers hebben nu toegang tot

{% I18n_Headers %}

zonder een URL op te geven, die gaat standaard naar site.url

Polyglot 1.2.0

Een nieuwe versie van Polyglot is gepubliceerd! Probeer het uit!

gem install jekyll-polyglot

en neem jekyll-polyglot op in je lijst van gems in je _config.yml

Het gaat vooral om voorbereidingen voor nieuwe features en betere meertalig contentbeheer. Het heeft ook een nieuwe feature:

{% I18n_Headers %}

Plaats deze tag met de URL van je website in je head.html om de maximale SEO te krijgen van een meertalige website. Het is hetzelfde als de volgende liquid code:

<meta http-equiv="Content-Language" content="{{site.active_lang}}">
<link rel="alternate"
      hreflang="{{site.default_lang}}"
      href="http://yoursite.com{{page.permalink}}" />
{% for lang in site.languages %}
{% if lang == site.default_lang %}
  {% continue %}
{% endif %}
<link rel="alternate"
    hreflang="{{lang}}"
    href="http://yoursite.com/{{lang}}{{page.permalink}}" />
{% endfor %}

In je header, maar sneller en netter! Voor meer informatie, zie de SEO-pagina

Polyglot versie 1.1.0

Polyglot ondersteunt nu volledig Jekyll 3.0-blogs! Ga het uitproberen!

gem 'jekyll-polyglot', '~> 1.1.0'